ODC - 1CP fails due to build timeout (OS-DPL-BLD-40801)

Incident Report for OutSystems

Postmortem

On October 30th, between 18:55 UTC and 21:22 UTC, customers experienced degraded success rates and timeouts when using the 1-Click Publish functionality. The issue, caused by an internal system component, was identified and resolved by our engineering team through a service restart, which immediately restored normal operation by 9:22 PM WET.

Posted Nov 13, 2025 - 15:48 UTC

Resolved

We have confirmed that all services in the eu-central-1(Frankfurt) region are now fully operational. Our team applied a fix by restarting an underlying service, which has restored normal performance. We will continue to investigate the root cause to prevent a recurrence.
Posted Oct 30, 2025 - 21:24 UTC

Investigating

We are aware of an issue affecting the 1-Click Publish service in the eu-central-1 (Frankfurt) region. Customers performing application deployments may experience build timeouts or failures.
Our team is currently investigating its cause. We will provide an update as soon as more details are available.
Posted Oct 30, 2025 - 20:46 UTC
This incident affected: ODC - Platform and Portal (Europe / Frankfurt).