Mentor Features Unavailable

Incident Report for OutSystems

Postmortem

Between July 3rd and July 5th, 2025, customers in multiple regions experienced intermittent issues with Mentor features. The disruptions stemmed from a failure during a service deployment that impacted the stability of the underlying infrastructure. While the overall incident duration was approximately 30 hours, customer-facing impact was limited and sporadic, with most functionality remaining available during the affected period.
The root cause was a combination of deployment inconsistencies and environment misalignments that surfaced during the release process. Recovery was achieved by deploying a revised and stabilized version of the service.
To prevent future occurrences, work is underway to improve deployment validation processes, refine rollback mechanisms, and accelerate the implementation of a multi-region pre-production testing environment to catch region-specific issues earlier in the release cycle.

Posted Jul 15, 2025 - 11:00 UTC

Resolved

We are pleased to confirm that the issue impacting Mentor features has been resolved. All services are now operational.
Posted Jul 03, 2025 - 21:26 UTC

Investigating

We are currently investigating an issue impacting the availability of Mentor features for users across all regions. Users may be unable to access or utilize Mentor functionalities at this time. Our teams are actively working to resolve this. We will continue to provide updates as new information becomes available.
Posted Jul 03, 2025 - 20:53 UTC
This incident affected: Mentor (US East / Virginia, South America / São Paulo, Europe / London, Europe / Frankfurt, Israel / Tel Aviv, Middle East / UAE, Asia Pacific / Mumbai, Asia Pacific / Singapore, Asia Pacific / Seoul, Asia Pacific / Tokyo, Asia Pacific / Sydney).