Incident affecting App promotion / Promote and Portal visibility in multiple regions

Incident Report for OutSystems

Postmortem

On February 6, 2025, at 11:41 UTC, we experienced an issue affecting App promotion / Promote and Portal visibility in multiple regions, preventing customers from tenants created after January 30th, from developing applications as they're unable to edit or deploy them. Normal service was restored at 17:19 UTC.

The incident was caused by the implementation of new features in ODC, where changes to an underlying feature on a service introduced some inconsistencies in the Platform Data Model.

To prevent new occurrences, the offending changes to the platform data model were reverted, which resolved the issue and enabled the customers to resume their operations.

Posted Feb 12, 2025 - 11:19 UTC

Resolved

The incident has been resolved, the affected customers will now be able to publish and access the deployed assets in Portal.
This incident has been resolved and is now operating as expected.
Posted Feb 07, 2025 - 17:06 UTC

Identified

We are aware of an issue affecting App promotion / Promote and Portal visibility in multiple regions: This is preventing customers from tenants created after January 30th, from essentially developing applications as they're unable to edit or deploy them.
Our team is actively working on a solution and will share updates once we have more details.
Posted Feb 07, 2025 - 14:59 UTC
This incident affected: ODC - Platform and Portal (South America / São Paulo, Europe / Frankfurt, Asia Pacific / Singapore, Asia Pacific / Tokyo, Asia Pacific / Sydney).