External authentication issues (502 error) when logging into ODC with External IdPs in all regions

Incident Report for OutSystems

Postmortem

On October 20, some customers across all regions experienced issues logging in using external Identity Providers (IdPs), receiving an error or not being redirected to complete authentication. A temporary workaround was provided while the root cause, a faulty service version introduced in recent updates, was identified and reverted.

The issue was fully resolved on October 20 at 18:15 UTC, restoring normal login functionality for all customers. The incident duration was extended due to an unrelated AWS outage that impacted service rollback times.

We apologize for the inconvenience and appreciate your patience while we restored full functionality.

Posted Oct 22, 2025 - 07:32 UTC

Resolved

The fix has been deployed in all regions. Our team reverted the service version that was causing authentication errors, and the process was successfully completed across all regions.
All services have been fully restored, and this incident is now resolved.
Posted Oct 20, 2025 - 16:21 UTC

Investigating

We are investigating an issue affecting external authentication. Customers in US (Virginia) and Asia Pacific (Tokyo) regions may encounter errors or may not be redirected to the External IdP page to complete the authentication flow as expected.

Our team is actively working on a solution and will provide an update as soon as more information becomes available.
Posted Oct 20, 2025 - 14:57 UTC
This incident affected: ODC - Identity & Access Management (US East / Virginia, Asia Pacific / Tokyo).