Intermittent Errors Affecting ODC Studio Publishing and Portal Access in Europe/Frankfurt

Incident Report for OutSystems

Postmortem

On July 14th, customers in the Europe region experienced intermittent errors when publishing applications in ODC Studio, along with issues accessing Organization roles in the ODC Portal. While publishing actions generally succeeded, the sporadic nature of the errors disrupted development workflows and prevented role management for some users. The issue was caused by an internal service component that was not processing updates as expected, resulting in permission and communication errors on ODC Studio and Portal. The problem was quickly identified and mitigated through targeted corrective actions. The system is now stable, and a long-term fix is being implemented to prevent recurrence.

Posted Jul 15, 2025 - 09:36 UTC

Resolved

We're pleased to confirm that the Intermittent Errors Affecting ODC Studio Publishing and Portal Access in Europe/Frankfurt have been resolved. Our teams have completed the necessary actions to restore full service, and the platform is now operating normally.
Posted Jul 14, 2025 - 19:38 UTC

Investigating

We are currently investigating intermittent issues impacting ODC Studio publishing, and general portal navigation for customers in the affected Frankfurt region. Our teams are actively working to identify the root cause and implement a resolution. We will continue to provide updates as new information becomes available.
Posted Jul 14, 2025 - 15:45 UTC
This incident affected: ODC - Customer Apps & Data (Europe / Frankfurt), ODC - Platform and Portal (Europe / Frankfurt), and ODC - Identity & Access Management (Europe / Frankfurt).