Incident affecting timer logs

Incident Report for OutSystems

Postmortem

On October 20, some customers noticed duplicate timer execution logs appearing in the console. A fix was implemented to address this issue.
On November 3, another issue occurred in which parts of the timer log display were missing in the console. The investigation determined that the problem originated from a faulty service version introduced in a recent update. The affected version was identified and fixed.
The issue was fully resolved on November 7 at 13:07 UTC, and normal log visibility is now available for all customers.

We sincerely apologize for the inconvenience and appreciate your patience while we worked to restore full functionality.

Posted Nov 10, 2025 - 12:00 UTC

Resolved

This incident has been fully resolved.
Our teams identified an issue that was affecting timer logs. A fix was developed, tested, and successfully applied to all environments. Monitoring confirms that the issue is now fully resolved.
Thank you for your patience and understanding.
Posted Nov 07, 2025 - 12:38 UTC

Monitoring

Upon investigation, our team has identified the root cause of the issue, and a fix is already being implemented.
We will continue to monitor the situation closely and post a final update once we confirm that all services are operating normally.
Posted Nov 06, 2025 - 19:59 UTC

Identified

The support teams have identified factors contributing to the incomplete log data and are actively working on a fix.
Monitoring and further analysis are ongoing, and updates will be provided as progress continues.
Posted Nov 06, 2025 - 17:30 UTC

Investigating

We are aware of an issue affecting Timer logs in Asia Pacific (Singapore) and US East (N. Virginia).
While the timers are running correctly, the logs may not be present.
Our team is currently investigating its cause. We will provide an update in as soon as more details are available.
Posted Nov 06, 2025 - 09:41 UTC
This incident affected: ODC - Platform and Portal (US East / Virginia, Asia Pacific / Singapore).