Incident affecting timeouts when deploying an app with external libraries packaged

Incident Report for OutSystems

Postmortem

On November 24, 2025, a new version of our deployment service was released, including an internal library update intended to optimize the processing of external libraries. This update inadvertently caused a logic error that made deployments hang during certain operations, leading to intermittent timeouts for customers deploying external libraries or applications that depend on them. Not all deployments were affected, and the impact varied by region and library volume. We immediately reverted the service to the previous stable version, restoring normal deployment operations.

We are working to correct the issue in the internal library and will reintroduce the optimization after thorough validation to prevent future disruptions.

We apologize for the inconvenience and appreciate your patience.

Posted Dec 03, 2025 - 15:20 UTC

Resolved

This incident has been fully resolved, and the Publish/Promote of External Libraries is now fully operating as expected.
Thank you for your patience.
Posted Nov 24, 2025 - 12:09 UTC

Identified

We are aware of an issue where deploying an app with an external library to other stages results in a timeout.

Our team is currently investigating the cause. We will provide an update as soon as more details are available.
Posted Nov 24, 2025 - 11:46 UTC
This incident affected: ODC - Customer Apps & Data (Europe / Frankfurt).