Incident affecting ODC Portal Access

Incident Report for OutSystems

Postmortem

On July 1, 2025, customers from multiple regions, mainly APAC, Europe and the Middle East. experienced difficulties accessing Mentor's Workflow and App Editors, encountering “502 Bad Gateway” errors. The disruption was caused by a routing misconfiguration affecting access to specific Mentor assets in certain regions.
The root cause was promptly identified, and a rollback process was initiated at 14:45 UTC to address the issue. The remediation was successfully completed by 23:05 UTC, and full functionality has been restored for all impacted customers.

Posted Jul 02, 2025 - 15:12 UTC

Resolved

This incident has been fully resolved and the different services on ODC Portal are now operating as expected. Thank you for your patience.
Posted Jul 01, 2025 - 23:45 UTC

Update

Our teams are continuing to implement the bulk reconciliation process to all affected tenants.
We are actively monitoring its progress and will provide our next update as soon as new information becomes available.
Posted Jul 01, 2025 - 20:21 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 01, 2025 - 17:03 UTC

Update

Our teams are still progressing with a bulk remediation to ensure that no remaining tenants are impacted. Further updates will be provided as the work advances.
Posted Jul 01, 2025 - 17:01 UTC

Update

Our team has applied manual fixes for the tenants who reported to be affected. We are now progressing with a bulk remediation to ensure that no remaining tenants are impacted. Further updates will be provided as the work advances.
Posted Jul 01, 2025 - 13:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 11:56 UTC

Investigating

We are aware of an issue affecting access to ODC Portal in Europe (Frankfurt) and Asia Pacific (Singapore).
Customers may experience 502 errors when trying to access different services on ODC Portal. Mentor and workflow editors are also being affected.
We have identified the cause of this issue. Our team is actively working on a solution. We will provide an update once more details are available.
Posted Jul 01, 2025 - 11:50 UTC
This incident affected: ODC - Platform and Portal (Europe / Frankfurt, Israel / Tel Aviv, Middle East / UAE, Asia Pacific / Singapore, Asia Pacific / Tokyo, Asia Pacific / Sydney) and Mentor (Europe / Frankfurt, Israel / Tel Aviv, Middle East / UAE, Asia Pacific / Singapore, Asia Pacific / Seoul, Asia Pacific / Tokyo, Asia Pacific / Sydney).